re = /.*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)/m
str = 'c:\\Users\\victor\\Documents\\index.js
c:\\Users\\victor\\Documents\\some.js'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result