import Foundation
let pattern = #".*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
c:\Users\victor\Documents\index.js
c:\Users\victor\Documents\some.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)