# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^>(\S+).*\[([^][]*)]/>\2_\1/gm;t' <<< ">XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1"