import Foundation
let pattern = #"^>(\S+).*\[([^][]*)]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
>XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #">\2_\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)