use strict;
my $str = '>XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1';
my $regex = qr/^>(\S+).*\[([^][]*)]/mp;
my $subst = '>\\2_\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";