$re = '/^>(\S+).*\[([^][]*)]/m';
$str = '>XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1';
$subst = ">\2_\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;