// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^>(\S+).*\[([^][]*)]").unwrap();
let string = ">XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1";
let substitution = ">\\2_\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}