using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^>(\S+).*\[([^][]*)]";
string substitution = @">\2_\1";
string input = @">XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}