import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^>(\\S+).*\\[([^][]*)]";
final String string = ">XP_002499978.1 predicted protein [Micromonas commoda]\n\n"
+ ">Micromonas_commoda_XP_002499978.1";
final String subst = ">\\2_\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}