const regex = /^>(\S+).*\[([^][]*)]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^>(\\S+).*\\[([^][]*)]', 'gm')
const str = `>XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1`;
const subst = `>\2_\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);