re = /^>(\S+).*\[([^][]*)]/m
str = '>XP_002499978.1 predicted protein [Micromonas commoda]
>Micromonas_commoda_XP_002499978.1'
subst = '>\\2_\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result