import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "style='((.|\\n)*?)'";
final String string = "<a style='width: 68px;text-align:center'> < /a>\n"
+ "<a style='width: 68px;text-align:center;\n\n"
+ " padding:0cm 3.5pt 0cm 3.5pt;height:90.0pt'> < /a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}