// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)style='((.|\n)*?)'").unwrap();
let string = "<a style='width: 68px;text-align:center'> < /a>
<a style='width: 68px;text-align:center;
padding:0cm 3.5pt 0cm 3.5pt;height:90.0pt'> < /a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}