const regex = /style='((.|\n)*?)'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('style=\'((.|\\n)*?)\'', 'gm')
const str = `<a style='width: 68px;text-align:center'> < /a>
<a style='width: 68px;text-align:center;
padding:0cm 3.5pt 0cm 3.5pt;height:90.0pt'> < /a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}