use strict;
my $str = '<a style=\'width: 68px;text-align:center\'> < /a>
<a style=\'width: 68px;text-align:center;
padding:0cm 3.5pt 0cm 3.5pt;height:90.0pt\'> < /a>';
my $regex = qr/style='((.|\n)*?)'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}