#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()"]*\K""
Local $sString = "Any text and "much" "more" of it. Don't replace quotes here" & @CRLF & _
"CatchThis( no quotes here, "any more text" , "and so on and so forth...")" & @CRLF & _
"catchthat("some other text" , "or less")" & @CRLF & _
"some text in "between"" & @CRLF & _
"CatchAnything ( "even more" , "and more", no quotes there, "wall of text")" & @CRLF & _
"more ("text"""") and quotes after..."
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)