# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()\"]*\K\""
test_str = ("Any text and \"much\" \"more\" of it. Don't replace quotes here\n"
"CatchThis( no quotes here, \"any more text\" , \"and so on and so forth...\")\n"
"catchthat(\"some other text\" , \"or less\")\n"
"some text in \"between\"\n"
"CatchAnything ( \"even more\" , \"and more\", no quotes there, \"wall of text\")\n"
"more (\"text\"\"\"\") and quotes after...")
subst = "#"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.