import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:\\G(?!\\A)|Catch(?:This|That|Anything)\\s*\\()[^()\"]*\\K\"";
final String string = "Any text and \"much\" \"more\" of it. Don't replace quotes here\n"
+ "CatchThis( no quotes here, \"any more text\" , \"and so on and so forth...\")\n"
+ "catchthat(\"some other text\" , \"or less\")\n"
+ "some text in \"between\"\n"
+ "CatchAnything ( \"even more\" , \"and more\", no quotes there, \"wall of text\")\n"
+ "more (\"text\"\"\"\") and quotes after...";
final String subst = "#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}