use strict;
my $str = 'Any text and "much" "more" of it. Don\'t replace quotes here
CatchThis( no quotes here, "any more text" , "and so on and so forth...")
catchthat("some other text" , "or less")
some text in "between"
CatchAnything ( "even more" , "and more", no quotes there, "wall of text")
more ("text"""") and quotes after...';
my $regex = qr/(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()"]*\K"/p;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";