re = /(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()"]*\K"/
str = 'Any text and "much" "more" of it. Don\'t replace quotes here
CatchThis( no quotes here, "any more text" , "and so on and so forth...")
catchthat("some other text" , "or less")
some text in "between"
CatchAnything ( "even more" , "and more", no quotes there, "wall of text")
more ("text"""") and quotes after...'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result