using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()""]*\K""";
string substitution = @"#";
string input = @"Any text and ""much"" ""more"" of it. Don't replace quotes here
CatchThis( no quotes here, ""any more text"" , ""and so on and so forth..."")
catchthat(""some other text"" , ""or less"")
some text in ""between""
CatchAnything ( ""even more"" , ""and more"", no quotes there, ""wall of text"")
more (""text"""") and quotes after...";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}