const regex = /(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()"]*\K"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:\\G(?!\\A)|Catch(?:This|That|Anything)\\s*\\()[^()"]*\\K"', 'g')
const str = `Any text and "much" "more" of it. Don't replace quotes here
CatchThis( no quotes here, "any more text" , "and so on and so forth...")
catchthat("some other text" , "or less")
some text in "between"
CatchAnything ( "even more" , "and more", no quotes there, "wall of text")
more ("text"""") and quotes after...`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);