using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{5})[-. ](\d{6})";
string substitution = @"(one:\1) (two:\2) (three:3)";
string input = @"something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}