import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{5})[-. ](\\d{6})";
final String string = "something 01234 567890 around\n"
+ "aaa 01111-222111 bbbb\n"
+ "cccc 09876.543210 ddd\n";
final String subst = "(one:\\1) (two:\\2) (three:3)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}