re = /(\d{5})[-. ](\d{6})/m
str = 'something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
'
subst = '(one:\\1) (two:\\2) (three:3)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result