package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{5})[-. ](\d{6})`)
var str = `something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
`
var substitution = "(one:\1) (two:\2) (three:3)"
fmt.Println(re.ReplaceAllString(str, substitution))
}