import Foundation
let pattern = #"(\d{5})[-. ](\d{6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(one:\1) (two:\2) (three:3)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)