const regex = /(\d{5})[-. ](\d{6})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{5})[-. ](\\d{6})', 'gm')
const str = `something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
`;
const subst = `(one:\1) (two:\2) (three:3)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);