#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{2}).(\d{2}).(\d{2})"
Local $sString = "23.03.15" & @CRLF & _
"21.12.24" & @CRLF & _
""
Local $sSubst = "20$1-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)