re = /^(\d{2}).(\d{2}).(\d{2})/m
str = '23.03.15
21.12.24
'
subst = '20$1-$2-$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result