using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{2}).(\d{2}).(\d{2})";
string substitution = @"20$1-$2-$3";
string input = @"23.03.15
21.12.24
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}