import re
regex = re.compile(r"^(\d{2}).(\d{2}).(\d{2})", flags=re.MULTILINE)
test_str = ("23.03.15\n"
"21.12.24\n")
subst = "20$1-$2-$3"
result = regex.sub(subst, test_str)
if result:
print(result)