$re = '/^(\d{2}).(\d{2}).(\d{2})/m';
$str = '23.03.15
21.12.24
';
$subst = "20$1-$2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;