# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\\/)(?:[-\w!#$]+)(.*?)$/$1examples$2/gm;t' <<< "/questions-math/ask/1
/questions/ask/1"