use strict;
my $str = '/questions-math/ask/1
/questions/ask/1';
my $regex = qr/^(\/)(?:[-\w!#$]+)(.*?)$/mp;
my $subst = '$1examples$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";