package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\/)(?:[-\w!#$]+)(.*?)$`)
var str = `/questions-math/ask/1
/questions/ask/1`
var substitution = "$1examples$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}