import re
regex = re.compile(r"^(\/)(?:[-\w!#$]+)(.*?)$", flags=re.MULTILINE)
test_str = ("/questions-math/ask/1\n"
"/questions/ask/1")
subst = "$1examples$2"
result = regex.sub(subst, test_str)
if result:
print(result)