// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\/)(?:[-\w!#$]+)(.*?)$").unwrap();
let string = "/questions-math/ask/1
/questions/ask/1";
let substitution = "$1examples$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}