const regex = /^(\/)(?:[-\w!#$]+)(.*?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/)(?:[-\\w!#$]+)(.*?)$', 'gm')
const str = `/questions-math/ask/1
/questions/ask/1`;
const subst = `$1examples$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);