using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/)(?:[-\w!#$]+)(.*?)$";
string substitution = @"$1examples$2";
string input = @"/questions-math/ask/1
/questions/ask/1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}