#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(:?[_a-z]+[_a-z0-9-]*)"
Local $sString = "px-3 " & @CRLF & _
"py-1 " & @CRLF & _
"rounded " & @CRLF & _
"@if(count($selected)) " & @CRLF & _
"bg-orange-400 " & @CRLF & _
"@else " & @CRLF & _
"bg-gray-200 " & @CRLF & _
"@endif " & @CRLF & _
"text-white " & @CRLF & _
"text-center"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")