$re = '/^(:?[_a-z]+[_a-z0-9-]*)/mi';
$str = 'px-3
py-1
rounded
@if(count($selected))
bg-orange-400
@else
bg-gray-200
@endif
text-white
text-center';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);