// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(:?[_a-z]+[_a-z0-9-]*)").unwrap();
let string = "px-3
py-1
rounded
@if(count($selected))
bg-orange-400
@else
bg-gray-200
@endif
text-white
text-center";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}