use strict;
my $str = 'px-3
py-1
rounded
@if(count($selected))
bg-orange-400
@else
bg-gray-200
@endif
text-white
text-center';
my $regex = qr/^(:?[_a-z]+[_a-z0-9-]*)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}