import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(:?[_a-z]+[_a-z0-9-]*)";
final String string = "px-3 \n"
+ "py-1 \n"
+ "rounded \n"
+ "@if(count($selected)) \n"
+ "bg-orange-400 \n"
+ "@else \n"
+ "bg-gray-200 \n"
+ "@endif \n"
+ "text-white \n"
+ "text-center";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}