import re
regex = re.compile(r"^(:?[_a-z]+[_a-z0-9-]*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("px-3 \n"
"py-1 \n"
"rounded \n"
"@if(count($selected)) \n"
"bg-orange-400 \n"
"@else \n"
"bg-gray-200 \n"
"@endif \n"
"text-white \n"
"text-center")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")