const regex = /^(:?[_a-z]+[_a-z0-9-]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(:?[_a-z]+[_a-z0-9-]*)', 'gmi')
const str = `px-3
py-1
rounded
@if(count(\$selected))
bg-orange-400
@else
bg-gray-200
@endif
text-white
text-center`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}