using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(:?[_a-z]+[_a-z0-9-]*)";
string input = @"px-3
py-1
rounded
@if(count($selected))
bg-orange-400
@else
bg-gray-200
@endif
text-white
text-center";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}