# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\\/?)b\b((?:[^>"']|"[^"]*"|'[^']*')*)>/<\1strong\2>/gm;t' <<< "asd <b> asd </b> sdsadfs
asdas <b class=\"xx\" title=\"asdasd\"> sdsdfasd </b>
"