package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(\/?)b\b((?:[^>"']|"[^"]*"|'[^']*')*)>`)
var str = `asd <b> asd </b> sdsadfs
asdas <b class="xx" title="asdasd"> sdsdfasd </b>
`
var substitution = "<\1strong\2>"
fmt.Println(re.ReplaceAllString(str, substitution))
}